Memory Error on exiting Phoenix

Reports of bugs and issues with Phoenix.
Ray King
Member
Posts: 26
Joined: Sat Sep 18, 2004 8:10 pm
Location: Connecticut USA
Contact:

Memory Error on exiting Phoenix

Postby Ray King » Mon Nov 22, 2004 1:11 pm

Hi Dominic,

Just wanted to say that I am still getting that Memory Error on exiting out of Phoenix.

Windows XP Pro 1Gig ram

Also, I now have the WinLift Simpify API working in Phoenix...

Thanks to Jose I also have the MS Agent working in Phoenix.

Enjoy
Ray

TechSupport
Site Admin
Posts: 809
Joined: Tue Sep 14, 2004 7:55 pm
Location: Mississauga ON, Canada

Postby TechSupport » Tue Nov 23, 2004 3:58 am

Thanks, I had forgotten about this problem. I did some research on this a while back and I think the only solution is to let the OS take care of memory deallocation on shutdown.
I will upload another prerelease of 1.0.5.0 with the modified code this weekend.

Herman Kieskamp
Member
Posts: 182
Joined: Mon Oct 11, 2004 12:55 pm
Location: Netherlands

Re: Memory Error on exiting Phoenix

Postby Herman Kieskamp » Sat Nov 27, 2004 10:07 am

Ray King wrote:Also, I now have the WinLift Simpify API working in Phoenix...

Thanks to Jose I also have the MS Agent working in Phoenix.

Ray


Care to share this with us ??? !!!
For example in source-section ?

Herman.

Ray King
Member
Posts: 26
Joined: Sat Sep 18, 2004 8:10 pm
Location: Connecticut USA
Contact:

Postby Ray King » Tue Nov 30, 2004 12:38 am

Hi Herman,

Share this! Of course, everyone knows that I give away my source as public domain.

But at the moment I have ran into some problems with it and Dominic is trying to help me fix them. Also something has happened to my web site so when I have the time I will redo it with a new web template.

The MS Agent is working in a WinLift Skinned Window, I am still adding all of the other Play commands etc to it. The problem I was having was with the script editor which Dominic has been kind enough to help me out with.

When finished the application will generate Javascript and PB/Win code.

Jose was kind enough to generate the com functions for me which are working very well. Thank you Dominic and Jose.

I love Phoenix and I will be writing all kinds of new stuff for it.

Thank you
Ray
Custom Software Designers.

Herman Kieskamp
Member
Posts: 182
Joined: Mon Oct 11, 2004 12:55 pm
Location: Netherlands

Postby Herman Kieskamp » Wed Dec 01, 2004 7:35 am

I thought you meant you had them embedded(custom control) in Phoenix,
i'd would like to know how.
I did not mean that you should share your source code !.
I have this AVI thingy I'd like to add as a custom control, but have no idea how ! Now I have a control loading line, and includes for methods en properties. It works, but not from within Phoenix. I hoped you had turned these into custom controls.

Herman.

B.T.W. I have a commandline driven Agent, very handy and funny for messages to people !

TechSupport
Site Admin
Posts: 809
Joined: Tue Sep 14, 2004 7:55 pm
Location: Mississauga ON, Canada

Postby TechSupport » Thu Dec 02, 2004 1:11 pm

Herman wrote:I have this AVI thingy I'd like to add as a custom control, but have no idea how !

Is it an ActiveX control or the brain dead one in Windows?

Ray King
Member
Posts: 26
Joined: Sat Sep 18, 2004 8:10 pm
Location: Connecticut USA
Contact:

Postby Ray King » Thu Dec 02, 2004 1:31 pm

I will put the AVI Custom Control on to my list and write it for you soon, I have already written one for PB so I will turn it into a Custom Control.

Ray

Herman Kieskamp
Member
Posts: 182
Joined: Mon Oct 11, 2004 12:55 pm
Location: Netherlands

Postby Herman Kieskamp » Sat Dec 04, 2004 9:13 am

It's plain windows, it's the winavi32 control of which Robert Valois has donated code to the source forum of pb. If you want I''ll send you the coding parts. I've been enhancing it a bit if I remember correctly.

But if you give me clues how to make it a custom control for Phoenix, I'll be happy to try to work it out myself. Is good for innersiteview of API-controls and Phoenix. Also challenging !!

Herman.

Herman Kieskamp
Member
Posts: 182
Joined: Mon Oct 11, 2004 12:55 pm
Location: Netherlands

Re: Memory Error on exiting Phoenix

Postby Herman Kieskamp » Fri Mar 24, 2006 11:58 am

Ray King wrote:Hi Dominic,

Also, I now have the WinLift Simpify API working in Phoenix...

Enjoy
Ray


Ray, I've been playing around to get winlift working for a application,
it does not seem to be intuitive.
Could/would you share with me/us where(and how) to put the init and skinwindow command ?

Herman.

TechSupport
Site Admin
Posts: 809
Joined: Tue Sep 14, 2004 7:55 pm
Location: Mississauga ON, Canada

Postby TechSupport » Fri Mar 24, 2006 1:25 pm

Could you provide a link to the WinLift simplified API?


Return to “Phoenix Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest